Dongle tester app

Why does my dongle not work? Is it working? What version is it? Why do only some of the values get displayed?

I recently discovered an app that can test a dongle and tell you what version it is, so also what features it implements:

https://play.google.com/store/apps/details?id=com.applagapp.elm327identifier&hl=en

Here is what the app produces for my MaxiScan dongles, which advertises itself as an v1.5 …

10 Comments on “Dongle tester app

  1. So do mine two I have. A black one, arriving yesterday and an older green one.

    Both signal 1.5 but produce exactly the same protocolls versions ending at 1.4.

    One even has a MAC address of FF:FF:FF:FF or so! What a hoax!

    Both cannot connect to the ECU of my ZOE, as revealed by the Torque Software.

  2. sorry. I did mean I use CanZE also. But there the same dysfunctionality. … and my comments in August show, my ZOEs OBD works with iCar Soft tool without problems.

  3. This is definitely a bad clone: weird MAC address: FF: all the way:

    ———————

    Scan datum=2017-12-04 11:04:45
    Geräte name=KONNWEI
    Geräte mac=FF:FF:FF:FF:FF:FF
    Die Geräte version (deklariert)=ELM327 v1.5

    Befehl Version Ergebnis
    AT@1 1.0 OK
    ATSPA6 1.0 OK
    ATTPA6 1.0 OK
    ATTP6 1.0 OK
    ATSP00 1.3 OK
    ATSP6 1.0 OK
    ATAL 1.0 OK
    ATNL 1.0 OK
    ATAMC 2.0 KO
    ATAMT20 2.0 KO
    ATRA70 1.3 OK
    ATSR70 1.2 OK
    ATAR 1.2 OK
    ATAT0 1.2 OK
    ATAT2 1.2 OK
    ATAT1 1.2 OK
    ATBD 1.0 OK
    ATBRT0F 1.2 OK
    ATCAF0 1.0 OK
    ATCAF1 1.0 OK
    ATCEA04 1.4 OK
    ATCERF1 2.2 KO
    ATCEA 1.4 OK
    ATCF00000111 1.0 OK
    ATCF111 1.0 OK
    ATCFC0 1.0 OK
    ATCFC1 1.0 OK
    ATCM00000111 1.0 OK
    ATCM111 1.0 OK
    ATCP18 1.0 OK
    ATCRA7C0 1.3 OK
    ATCRA000007C0 1.3 OK
    ATCRA 1.4b KO
    ATCS 1.0 OK
    ATCSM0 1.4b KO
    ATCSM1 1.4b KO
    ATCTM5 2.1 KO
    ATCTM1 2.1 KO
    ATCV0000 1.4 OK
    ATD1 1.3 OK
    ATD0 1.3 OK
    ATDP 1.0 OK
    ATDPN 1.0 OK
    ATE0 1.0 OK
    ATE1 1.0 OK
    ATFCSD0430FF00 1.1 OK
    ATFCSH000007B0 1.1 OK
    ATFCSH7B0 1.1 OK
    ATFCSM0 1.1 OK
    ATFE 1.3a OK
    ATH0 1.0 OK
    ATH1 1.0 OK
    ATI 1.0 OK
    ATIB10 1.0 OK
    ATIB12 2.2 KO
    ATIB15 2.2 KO
    ATIB48 1.4 OK
    ATIB96 1.0 OK
    ATIFRS 1.2 OK
    ATIFRH 1.2 OK
    ATIFR0 1.2 OK
    ATIFR2 1.2 OK
    ATIFR1 1.2 OK
    ATIFR6 2.2 KO
    ATIFR5 2.2 KO
    ATIFR4 2.2 KO
    ATIGN 1.4 OK
    ATIIA7A 1.2 OK
    ATJS 1.3 OK
    ATJE 1.3 OK
    ATJHF0 1.4b KO
    ATJHF1 1.4b KO
    ATJTM5 1.4b KO
    ATJTM1 1.4b KO
    ATKW 1.3 OK
    ATKW0 1.2 OK
    ATKW1 1.2 OK
    ATL0 1.0 OK
    ATL1 1.0 OK
    ATM1 1.0 OK
    ATM0 1.0 OK
    ATPPFFON 1.1 OK
    ATPPFFOFF 1.1 OK
    ATR0 1.0 OK
    ATR1 1.0 OK
    ATRV 1.0 OK
    ATS0 1.3 OK
    ATS1 1.3 OK
    ATSDFF 1.4 OK
    ATRD 1.4 OK
    ATSH000007E0 2.0 KO
    ATSHA848F1 1.0 OK
    ATSH7B0 1.0 OK
    ATST32 1.0 OK
    ATSWFF 1.0 OK
    ATTAF9 1.4 OK
    ATV1 1.3 OK
    ATV0 1.3 OK
    ATWMC133F13E 1.0 OK
    ATPC 1.0 OK
    ATWS 1.0 OK
    ATD 1.0 OK
    ATZ 1.0 OK

  4. The new designs KONNWEI 902 report MAC address FF:FF:FF:FF:FF:FF which is nasty when switching between dongles, but they actually work fine (as long as you don’t have two). It’s stupid but no hoax. Note that this model also had the resistor problem. If I were you I would check that problem first before focusing on the FF’s. But that’s my opinion of course.

  5. PS: I forgot to mention: Not sure about Torque, but Torque Light is absolutely useless on ZOE, it will not be able to connect whatsoever as it hunts for ECU’s the ZOE does not have. You know, engine control 😉

  6. Thank you for the response.

    I did hours of testing with the two dongles now. In the newer dongle I cut the 120 Ohm resistor yesterday already.

    With android “ELM327 OBD Terminal” I communicated with the dongles. I did find out that protocolls 6 and 7 work with the ZOE Can bus.
    Protocol 6: ISO 15765-4 (11 bit, 500 kBaud).

    But: “no data” reported after the “01 00” OBD command, and others too. Even when I did set the timeout via command: “AT ST FF” to the maximum.

    Finally using CanZE again. Good bluethooth connection, but not data transmitted. “ELM327 Dongle” test reports always this 2 lines:

    “Please wait until the poller thread has stopped a S^

    No connection. Please close this screen and check the connection”

    ————————
    Next steps:
    1) Buy an original ELM chip dongle, at 65 pounds in the UK, software 2.2. ?
    https://www.scantool-direct.co.uk/genuine-elm327-chip-scan-tool-obdii-eobd-bluetooth-diagnostic-interface.html

    2. Test my dongles in another ZOE, perhaps my CAN-bus wiring has some peculiarity.

    KR, Franz

  7. I just did your wounderful command prompt dongle test sequence. My green Konwei passed everthing and reported every second a line on the “at ma” command. ! I will reinstall my CanZE now.

Leave a Reply to Bob Fisch Cancel reply