Dark mode and sun-setting Android 4 support

In the next release we plan to introduce dark mode for Android 9 and 10 devices. It probably will not be settable in CanZE itself but will follow Android’s native setting.

Until now, we’ve been keeping CanZE compatible with API level 15, meaning Android 4.0.3. For reference, we’re talking Samsung S2 era, early 2012 phones. To make dark mode work without over-complicating the code, we have to let go of supporting Android 4 and make API level 21 the minimum requirement. These are late 2014/early 2015 phones. The number of active users below API level 21 is below 1% of the active users, so we feel this is a fair compromise.

The sun-setting of Android 4 support has been announced starting today in the news bar. If you run CanZE on an Android 4 device it will no longer receive updates.

Leave a Reply