Charger startup sequence

We’ve had somewhat of a blank spot when it comes to the start of a charging session. Understanding it well can help diagnosing why the car might refuse. SpeakEV user ElectricBeagle bit the bullet and started measuring currents in all the leads to find out what is going on. For brevity, I assume that the cable is in and locked, connecting protective earth [PE] to the car’s chassis, and everything to activate the chargepoint is done. The main contactor in the chargepoint is about to close.

  • The main contactor is closed in the chargepoint. This usually creates a significant current spike in the lead(s) as all L lines have a 100 uF capacitor to N, see the blue box in the third picture of this post. Correction: pretty sure now the capacitors are in a delta configuration, not a star.
  • Car allows for dampening out ringing for a second or two. Note that because of the capacitors, a significant though reactive current (6A per lead) is drawn. This is, ignoring some losses, not a power uptake.
  • The car injects two 20 mA pulses between PE  and N in both polarities to measure earth resistance. If the resulting voltage exceeds 4 V, meaning an earth resistance of more than 200 ohms, the charge point is rejected. *)
  • The car ramps up power uptake from 0 to the requested power in about one second. It’s very gradual, which is also notable in the ramp up of the “whine”.

Maybe you remember fairy tales about > 500 A startup currents by the ZOE, usually told by chargepoint mechanics. Well, this is what it is, a 100 uF capacitive load. Because of lead resistance and filter coils, inrush is actually limited and the spikes are 30 – 50 amps and last about one ms. This is no big deal whatsoever and any notion that this is problematic can be dismissed.

Now there are other tests done such as lead voltage and earth leak current, but these test can not be detected, though they should be pretty straight forward. I read of one driver seeing it’s car still charge on 180 V from an off grid PV system. I don’t know if the car would actually start a session this low.

I am now tempted to build myself an Arduino based earth tester using the same principle as have an extra diagnostic tool. For the Netherlands though, this is hardly worth the effort as most, if not all chargepoints are connected using decent earthing.

I’ll write in another post about the currents while charging.

*) Entire books have been written about safe earthing of power distribution networks. For the technically inclined Dutchies (or the ones who can bear Google Translate), this is such a book, link to the relevant part. I will only say here that ZOE of course is unable to have a true earth reference. So she assumes a network where N and PE are actually connected. In modern TN-C-S networks this should always be the case. In TT networks, where earth is provided with a local earth rod, things might not work out that way, let alone floating or midpoint-earthed networks. These are dying breeds but still all over Europe, especially in the more rural areas.

9 Comments on “Charger startup sequence

  1. Dear Jeroen,
    I have a 2013 Zoe. I have recently started to (try) using a bunch of chargers in a parking house, and a bunch outside the parking house, all them installed by the same company. Quite often (3 out of 4 times) my Zoe will not start charging from any of these chargers, I suspect due to poor earthing. But, it is not clear to me if I have access to this information through CanZE. Do you know if there is a parameter in CanZE that can be read out, indicating the type of error the car experiences (e.g. not passing the earth check)?
    Thanks
    Jens

    • I am pretty sure what is displayed in the charging screen in the technical section shows the LAST earth resistance value. That should work for you. From memory it should be below 100 or 150 ohms depending on firmware version. I have never concentrated much on the DTC codes, but you could have a look at those. You need to have a look at the ones for the BCB.

      A 2013 car should be a Q210, like mine is. My advice would be to check if you have fairly recent car firmware. Go to that screen an check the LBC (that’s the battery). Tap it and the “Soft” at at the bottom should be 0854 or higher. BCB should be 0740 or higher. In my experience it fixed a lot of dodgy charging problems.

  2. Thanks for the App and these posts – brilliant & most helpfull! My domestic charge point just stopped working and my ZE40 (2017)showing the red ZE at the connector. I had to try several local charge points before I found one working to firstly check the car was OK.. So back at home your App told me the ground resistance was 175Ohms. Tipped some water over the earth rod (presumably reducing the resistance to earth) and the car then started charging and on checking the App it now reports 135 Ohms. Seems like I need to add some extra earth rods! Prior to this I had opened the charge point and with a dmm I could read 4V ac between neutral and earth and this actually went up to about 4.3V ac with the car charging (maybe due to the voltage drop down the neutral cable. When its charged & I’ve install some extra earth rods I’ll have a look at the N to ground voltage.

  3. Hi Just a footnote. A few hours later the car would not charge again so I checked the ground resistance and found it was reading 163 Ohms. So I poured some salted water on and around the earth rod and the ground resistance dropped to 85 Ohms and car was happy again. I’m going to get my electricity supplier to sort out the earthing of my supply because its very clear now what my occasional problems with my charge point was caused by.
    Thanks again!

    • Wonderful news. An easy diagnostic for a change. And it confirms the later models have their cutoff at 150 ohms.

      Looks like you do not have a TN-CS earth system provided by your grid operator, and thus have to rely on earth rods. In any case 1750 ohms is way too high for the safety of your house. Glad ZOE found what should be considered a serious issue.

  4. Hi Jeroen, Thanks I have them coming to sort my supply earthing. My original ground resistance was actually 175 Ohms and the Zoe did not like this or 165 Ohms but was OK at 135 Ohms. This suggests the threshold is perhaps 150 Ohms as you suggest above.

  5. Hi Jeroen,
    My 2017 ZOE has developed the red nose when trying to charge and the dash says check vehicle plug. I’ve checked the continuity of the connections from the earth pin and the 3 phases and N from the charge port through to the end of the cable that connects into the motor/charger block and all seems well. The control pilot and proximity pilot seem to connect separately into the block much lower down on the left. When I try and charge from my home charge point it doesn’t get as far as closing the contactors and the red nose on the car seems to light the instant the cable is plugged in (almost before the motor locks it). I am suspecting a fault with the proximity pilot? If I measure with my multimeter the resistance between the central earth pin (black meter lead) on the car charge port and the proximity pilot top right (red meter lead I read 2.62MOhm. If I switch to diode test it reads 2.179V. These are both with the big red AC power connector plugged back into the motor/charger block.
    Do you know whether these readings are to be expected?

    I have read that problems have been reported with the charge port cable assembly but I’ve not come across detail on what faults have occurred.

    With your App the car seems to detect the current capability of the charge point it is connected to (8A granny cable, 30A home charge point, 90 A public 3 phase so this suggestes the control pilot function is OK. In all cases 0 phase voltages are reported in the charging page of the APP.

    Any pointers you can give would be much appreciated!!

    Best regards,

    Simon

    ps my grounding was fixed by the supplier and the App reports 0 Ohms

Leave a Reply